re = /\w*(?<=[^\Wz])zz(?=[^\Wz])\w*/m
str = 'buzz foozzbar zzbar wazzu trizzzbar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end