$re = '/^[a-zA-Z0-9._%+-]+@(kokoko\.com|koko\.com)$/m';
$str = 'ashghjsdf@gmail.com
sdjhjkdfg@kokoko.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);