re = /^[a-zA-Z0-9._%+-]+@(kokoko\.com|koko\.com)$/m
str = 'ashghjsdf@gmail.com
sdjhjkdfg@kokoko.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end