import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!-0$)-?[0-9][0-9]{0,2}$";
final String string = "-999\n"
+ "0\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "9\n"
+ "99\n"
+ "-99\n"
+ "-100\n"
+ "999\n"
+ "-0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}