#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^trigger\/(appstore|develop)-\d+\.\d+\.\d+\.\d+$"
Local $sString = "trigger/appstore-1.2.3.4" & @CRLF & _
"trigger/appstore-5.6.7.8" & @CRLF & _
"trigger/appstore-1.22.333.4444" & @CRLF & _
"trigger/develop-1.2.3.4" & @CRLF & _
"_trigger/appstore-1.2.3.4" & @CRLF & _
"trigger/appstore-1.2.3.4_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")