// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^trigger\/(appstore|develop)-\d+\.\d+\.\d+\.\d+$").unwrap();
let string = "trigger/appstore-1.2.3.4
trigger/appstore-5.6.7.8
trigger/appstore-1.22.333.4444
trigger/develop-1.2.3.4
_trigger/appstore-1.2.3.4
trigger/appstore-1.2.3.4_";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}