package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b\S+\s*){5}`)
var str = `After reading this dfds f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}