$re = '/(?:\b\S+\s*){5}/m';
$str = 'After reading this dfds f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);