use strict;
my $str = '372591089, jni, oduction, to, A, hnr, android, -"The, mAt,352, 268, 638, 257, 65, JI, 0, 00, 0, 0, al, 31/07/2015, oHa, Jile, 786118029,';
my $regex = qr/(\d{3}\,\s\d{3}\,\s\d{3}\,\s\d{3}\,\s\d{2}\,)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}