# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{3}\,\s\d{3}\,\s\d{3}\,\s\d{3}\,\s\d{2}\,)"
test_str = "372591089, jni, oduction, to, A, hnr, android, -\"The, mAt,352, 268, 638, 257, 65, JI, 0, 00, 0, 0, al, 31/07/2015, oHa, Jile, 786118029,"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.