#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+(\..+)+(?=")"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "key1": "value"," & @CRLF & _
" "key2": {" & @CRLF & _
" "word1.word2.word3.word4.interestingPart": {" & @CRLF & _
" "key1": "value"," & @CRLF & _
" "key2": "value"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "key3": "value"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "key1": "value"," & @CRLF & _
" "key2": {" & @CRLF & _
" "word1.word2.word3.word4.word5.word6.thisIsAlsoAnInterestingPart": {" & @CRLF & _
" "key1": "value"," & @CRLF & _
" "key2": "value"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "key3": "value"" & @CRLF & _
" }" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")