import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(\\..+)+(?=\")";
final String string = "[\n"
+ " {\n"
+ " \"key1\": \"value\",\n"
+ " \"key2\": {\n"
+ " \"word1.word2.word3.word4.interestingPart\": {\n"
+ " \"key1\": \"value\",\n"
+ " \"key2\": \"value\"\n"
+ " }\n"
+ " },\n"
+ " \"key3\": \"value\"\n"
+ " },\n"
+ " {\n"
+ " \"key1\": \"value\",\n"
+ " \"key2\": {\n"
+ " \"word1.word2.word3.word4.word5.word6.thisIsAlsoAnInterestingPart\": {\n"
+ " \"key1\": \"value\",\n"
+ " \"key2\": \"value\"\n"
+ " }\n"
+ " },\n"
+ " \"key3\": \"value\"\n"
+ " }\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}