using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*[^A-Z])([A-Z]+)$";
string input = @"Ricky RubioPHX
Luka DoncicDAL
Ben SimmonsPHI
Trae YoungATL
Devonte' GrahamCHA
Damian LillardPOR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}