re = /^(.*[^A-Z])([A-Z]+)$/m
str = 'Ricky RubioPHX
Luka DoncicDAL
Ben SimmonsPHI
Trae YoungATL
Devonte\' GrahamCHA
Damian LillardPOR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end