$re = '/(?!-)(?:(?:^|-)\w{4}){4}$/m';
$str = 'aaaa-aaaa-aaaa-aaaa-aaaa
aaaa-aaaa-aaaa-aaaa
aaaaaaaaaaaaaaaa
-aaaa-aaaa-aaaa-aaaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);