re = /(?!-)(?:(?:^|-)\w{4}){4}$/m
str = 'aaaa-aaaa-aaaa-aaaa-aaaa
aaaa-aaaa-aaaa-aaaa
aaaaaaaaaaaaaaaa
-aaaa-aaaa-aaaa-aaaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end