$re = '/![[].*[\/].*_image[0-9].png[]]]/m';
$str = '# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;