re = /![[].*[\/].*_image[0-9].png[]]]/m
str = '# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/Abracadabra_image2.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result