import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#EXT-X-PROGRAM-DATE-TIME:(.*)(?:\\n(?!seg\\d+\\.ts$).*)*\\nseg2\\.ts$";
final String string = "#EXTM3U\n"
+ "#EXT-X-VERSION:3\n"
+ "#EXT-X-ALLOW-CACHE:NO\n"
+ "#EXT-X-TARGETDURATION:7\n"
+ "#EXT-X-MEDIA-SEQUENCE:0\n\n"
+ "#EXT-X-PROGRAM-DATE-TIME:2022-09-12T10:03:22.621+02:00\n"
+ "#EXTINF:6.666666667,\n"
+ "seg1.ts\n"
+ "#EXT-X-PROGRAM-DATE-TIME:2022-09-12T10:03:29.637+02:00\n"
+ "#EXTINF:6.666666667,\n"
+ "seg2.ts\n"
+ "#EXT-X-PROGRAM-DATE-TIME:2022-09-12T10:03:36.583+02:00\n"
+ "#EXTINF:6.666666666,\n"
+ "seg3.ts";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}