import re
regex = re.compile(r"^#EXT-X-PROGRAM-DATE-TIME:(.*)(?:\n(?!seg\d+\.ts$).*)*\nseg2\.ts$", flags=re.MULTILINE)
test_str = ("#EXTM3U\n"
"#EXT-X-VERSION:3\n"
"#EXT-X-ALLOW-CACHE:NO\n"
"#EXT-X-TARGETDURATION:7\n"
"#EXT-X-MEDIA-SEQUENCE:0\n\n"
"#EXT-X-PROGRAM-DATE-TIME:2022-09-12T10:03:22.621+02:00\n"
"#EXTINF:6.666666667,\n"
"seg1.ts\n"
"#EXT-X-PROGRAM-DATE-TIME:2022-09-12T10:03:29.637+02:00\n"
"#EXTINF:6.666666667,\n"
"seg2.ts\n"
"#EXT-X-PROGRAM-DATE-TIME:2022-09-12T10:03:36.583+02:00\n"
"#EXTINF:6.666666666,\n"
"seg3.ts")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")