package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\"linkedIn)(?:\"\s?:\s?\")(.*)(?:\")`)
var str = `{
"linkedIn": "https://www.linkedin.com/in/amireng/"
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}