package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d-]`)
var str = `a=<-1,23,-3> b=<422,-5,6>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}