$re = '/[^\d-]/';
$str = 'a=<-1,23,-3> b=<422,-5,6>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);