using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.+).*),(?!.*(?=\1)(((?=(..+)(\5+$))\6)*)(?!\2)).*(?=\1)\K(?3)\2$";
string input = @"111,11111
11111,11111111111
111111111,11111111111
111111111,1111111111111111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}