import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((.+).*),(?!.*(?=\\1)(((?=(..+)(\\5+$))\\6)*)(?!\\2)).*(?=\\1)\\K(?3)\\2$";
final String string = "111,11111\n"
+ "11111,11111111111\n"
+ "111111111,11111111111\n"
+ "111111111,1111111111111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}