const regex = new RegExp('[A-Z]*(?: +[A-Z]*){4,}', 'g')
const str = `This reges should capture repeated words WRITTEN IN UPPERCASE ONE AFTER THE other.
\\*literal asterisks\\*
Markdown provides backslash escapes for the following characters:
\\ backslash
\` backtick
* asterisk
_ underscore
{} curly braces
[] square brackets
() parentheses
# hash mark
+ plus sign
- minus sign (hyphen)
. dot
! exclamation mark
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}