# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Z]*(?: +[A-Z]*){4,}"
test_str = ("This reges should capture repeated words WRITTEN IN UPPERCASE ONE AFTER THE other.\n\n"
" \\*literal asterisks\\*\n\n"
"Markdown provides backslash escapes for the following characters:\n\n"
" \\ backslash\n"
" ` backtick\n"
" * asterisk\n"
" _ underscore\n"
" {} curly braces\n"
" [] square brackets\n"
" () parentheses\n"
" # hash mark\n"
" + plus sign\n"
" - minus sign (hyphen)\n"
" . dot\n"
" ! exclamation mark\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.