using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<indent>\s*)(?P<type>[\w]+)\s(?P<identifier>[\w\d]+)\s*=\s*";
string input = @" int derp_errino = ""derpieer.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}