re = /(?P<indent>\s*)(?P<type>[\w]+)\s(?P<identifier>[\w\d]+)\s*=\s*/
str = ' int derp_errino = "derpieer."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end