const regex = /(?(DEFINE)
(?<Collection>
(?:(?&GameTree)(?:\s*(?&GameTree))*)?
)
(?<GameTree>
\(\s*
(?&RootNode)\s*
(?&NodeSequence)\s*
(?:(?&Tail)(?:\s*(?&Tail))*)?\s*
\)
)
(?<Tail>
\(\s*
(?&NodeSequence)\s*
(?:(?&Tail)(?:\s*(?&Tail))*)?\s*
\)
)
(?<NodeSequence>
(?:(?&Node)(?:\s*(?&Node))*)?
)
(?<RootNode> (?&Node) )
(?<Node> ;\s*(?:(?&Property)(?:\s*(?&Property))*)? )
(?<Property>
(?&PropIdent)\s*
(?&PropValue)(?:\s*(?&PropValue))*
)
(?<PropIdent> [A-Z](?:\s*[A-Z])* )
(?<PropValue> \[ (?&Value) \])
(?<Value> (?:\\\]|[^\]])* )
)
(?&Property)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<Collection>
(?:(?&GameTree)(?:\\s*(?&GameTree))*)?
)
(?<GameTree>
\\(\\s*
(?&RootNode)\\s*
(?&NodeSequence)\\s*
(?:(?&Tail)(?:\\s*(?&Tail))*)?\\s*
\\)
)
(?<Tail>
\\(\\s*
(?&NodeSequence)\\s*
(?:(?&Tail)(?:\\s*(?&Tail))*)?\\s*
\\)
)
(?<NodeSequence>
(?:(?&Node)(?:\\s*(?&Node))*)?
)
(?<RootNode> (?&Node) )
(?<Node> ;\\s*(?:(?&Property)(?:\\s*(?&Property))*)? )
(?<Property>
(?&PropIdent)\\s*
(?&PropValue)(?:\\s*(?&PropValue))*
)
(?<PropIdent> [A-Z](?:\\s*[A-Z])* )
(?<PropValue> \\[ (?&Value) \\])
(?<Value> (?:\\\\\\]|[^\\]])* )
)
(?&Property)', 'g')
const str = `GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}