$re = '/(?(DEFINE)
(?<Collection>
(?:(?&GameTree)(?:\s*(?&GameTree))*)?
)
(?<GameTree>
\(\s*
(?&RootNode)\s*
(?&NodeSequence)\s*
(?:(?&Tail)(?:\s*(?&Tail))*)?\s*
\)
)
(?<Tail>
\(\s*
(?&NodeSequence)\s*
(?:(?&Tail)(?:\s*(?&Tail))*)?\s*
\)
)
(?<NodeSequence>
(?:(?&Node)(?:\s*(?&Node))*)?
)
(?<RootNode> (?&Node) )
(?<Node> ;\s*(?:(?&Property)(?:\s*(?&Property))*)? )
(?<Property>
(?&PropIdent)\s*
(?&PropValue)(?:\s*(?&PropValue))*
)
(?<PropIdent> [A-Z](?:\s*[A-Z])* )
(?<PropValue> \[ (?&Value) \])
(?<Value> (?:\\\\\]|[^\]])* )
)
(?&Property)/x';
$str = 'GM[1]FF[4]CA[UTF-8]AP[Sabaki:0.52.2]KM[6.5]SZ[19]DT[2023-12-25]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);