package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/.+\..+$`)
var str = `/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}