re = /\/.+\..+$/
str = '/Volumes/Server/Order/138000/138625 - Customer Name/Production/138625_1_67x14.2_x2.pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end