use strict;
my $str = '# MATCH
Series S43E03 1080p WEB-DL DDP 5.1 H.264-CAKES
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GGEZ
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GGWP
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GLHF
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GOSSIP
Series S43E03 1080p WEB-DL DDP 5.1 H.264-KOGi
Series S43E03 1080p WEB-DL DDP 5.1 H.264-PECULATE
Series S43E03 1080p WEB-DL DDP 5.1 H.264-SLOT
Series S43E03 1080p WEB DDP 5.1 H.264--RlsGrp
Movie.2022.MULTI.HDR.2160p.WEB.H265-LOST
Movie.2022.iNTERNAL.HDR.2160p.WEB.H265-NAISU
Movie.2022.DV.2160p.WEB.H265-NAISU
Movie.2022.OAR.1080p.WEB.H264-SLOT
Movie.2022.1080p.WEB.H264-NAISU
Movie.2022.720p.WEB.H264-SLOT
# DON\'T MATCH
Movie.2022.1080p.NF.WEB-DL.DDP5.1.Atmos.x264-RlsGrp
Show.S01.1080p.AMZN.WEB.DL.DD5.1.H.264-RlsGrp
Title.Web.2006.1080p.WEB.DL.DD5.1.H.264-RlsGrp
Show.Title.S05E07.Episode.Title.Web.2006.1080p.WEB.DL.DD5.1.H.264-RlsGrp
';
my $regex = qr/^(?=.*(\b\d{3,4}p\b)([_. ]WEB[_. ])(?!DL)\b)|\b(-CAKES|-GGEZ|-GGWP|-GLHF|-GOSSIP|-NAISU|-KOGI|-PECULATE|-SLOT|-EDITH|-ETHEL|-ELEANOR|-B2B|-SPAMnEGGS|-FTP|-DiRT|-SYNCOPY|-BAE|-SuccessfulCrab|-NHTFS|-SURCODE|-B0MBARDIERS)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}