import Foundation
let pattern = #"^(?=.*(\b\d{3,4}p\b)([_. ]WEB[_. ])(?!DL)\b)|\b(-CAKES|-GGEZ|-GGWP|-GLHF|-GOSSIP|-NAISU|-KOGI|-PECULATE|-SLOT|-EDITH|-ETHEL|-ELEANOR|-B2B|-SPAMnEGGS|-FTP|-DiRT|-SYNCOPY|-BAE|-SuccessfulCrab|-NHTFS|-SURCODE|-B0MBARDIERS)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
# MATCH
Series S43E03 1080p WEB-DL DDP 5.1 H.264-CAKES
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GGEZ
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GGWP
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GLHF
Series S43E03 1080p WEB-DL DDP 5.1 H.264-GOSSIP
Series S43E03 1080p WEB-DL DDP 5.1 H.264-KOGi
Series S43E03 1080p WEB-DL DDP 5.1 H.264-PECULATE
Series S43E03 1080p WEB-DL DDP 5.1 H.264-SLOT
Series S43E03 1080p WEB DDP 5.1 H.264--RlsGrp
Movie.2022.MULTI.HDR.2160p.WEB.H265-LOST
Movie.2022.iNTERNAL.HDR.2160p.WEB.H265-NAISU
Movie.2022.DV.2160p.WEB.H265-NAISU
Movie.2022.OAR.1080p.WEB.H264-SLOT
Movie.2022.1080p.WEB.H264-NAISU
Movie.2022.720p.WEB.H264-SLOT
# DON'T MATCH
Movie.2022.1080p.NF.WEB-DL.DDP5.1.Atmos.x264-RlsGrp
Show.S01.1080p.AMZN.WEB.DL.DD5.1.H.264-RlsGrp
Title.Web.2006.1080p.WEB.DL.DD5.1.H.264-RlsGrp
Show.Title.S05E07.Episode.Title.Web.2006.1080p.WEB.DL.DD5.1.H.264-RlsGrp
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)