import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((https|http):\\/?\\/?)?(?<bucket>[a-z\\-]*)(\\.s3\\.)(?<server>[a-z\\-\\d]*)(\\.amazonaws\\.com\\/)(?<key>[^?\\s]*)(\\?)?(?<extra>\\??.*)";
final String string = "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/2iw99y1.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/advisor/anand%40pulse360.com/img/signature.png\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/company_logo.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/Entrega%202%20-%20Punto%206%20.png\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/tb.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/advisor/santiago.persico%40teracloud.io/img/signature.png\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/Lyrics.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/face2.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/arriba%20small%20compressed.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/vepPagado.pdf\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/Flyster---300px.jpg\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/Skull.png?asd=asd\n"
+ "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/2iw99y1.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}