$re = '/((https|http):\/?\/?)?(?<bucket>[a-z\-]*)(\.s3\.)(?<server>[a-z\-\d]*)(\.amazonaws\.com\/)(?<key>[^?\s]*)(\?)?(?<extra>\??.*)/i';
$str = 'https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/2iw99y1.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/advisor/anand%40pulse360.com/img/signature.png
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/company_logo.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/Entrega%202%20-%20Punto%206%20.png
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/tb.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/advisor/santiago.persico%40teracloud.io/img/signature.png
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/Lyrics.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/face2.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/arriba%20small%20compressed.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/vepPagado.pdf
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/Flyster---300px.jpg
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/Skull.png?asd=asd
https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/2iw99y1.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);