using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?(?: |^)(\d+)(?: \1){3}(?!\S)).*?(?: |^)(\d+)(?: \2){2}(?!\S)";
string input = @"I am 42 42 4 hey yoo
I am 42 42 42 hey yoo
I am 42 42 42 4 hey yoo
I am 42 42 42 42 hey yoo
foo 42 42 42 bar 42 42 42 42";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}