const regex = /^(?!.*?(?: |^)(\d+)(?: \1){3}(?!\S)).*?(?: |^)(\d+)(?: \2){2}(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?(?: |^)(\\d+)(?: \\1){3}(?!\\S)).*?(?: |^)(\\d+)(?: \\2){2}(?!\\S)', 'gm')
const str = `I am 42 42 4 hey yoo
I am 42 42 42 hey yoo
I am 42 42 42 4 hey yoo
I am 42 42 42 42 hey yoo
foo 42 42 42 bar 42 42 42 42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}