package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^000.*$`)
var str = `11111
00010
10001
10101
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}