#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<topro>\([^)]*?\bpro +)(?<afterpro>.*?\))|(?<withoutpro>\(.*?\))"
Local $sString = "4377631753733131 (pro alber con tr33)" & @CRLF & _
"886uhghsdfdsfh (pro cios tui tr32)" & @CRLF & _
"rtyqrey 6y46457 6372576 (Flrt ghnap tsr)" & @CRLF & _
"537657QQRFytyvg (flipzz Reyhdf frfg33)" & @CRLF & _
"" & @CRLF & _
"4377631753733131 (pro alber con tr33) (flipzz Reyhdf frfg33) (foo pro bar pro cios tui tr32)" & @CRLF & _
"" & @CRLF & _
"I would like all words after "pro" to be capitalized. If "pro" is not present, all words in the brackets must be lowercase, for have :" & @CRLF & _
"" & @CRLF & _
"4377631753733131 (pro Alber Con Tr33)" & @CRLF & _
"886uhghsdfdsfh (pro Cios Tui Tr32)" & @CRLF & _
"rtyqrey 6y46457 6372576 (flrt ghnap tsr)" & @CRLF & _
"537657QQRFytyvg (flipzz reyhdf frfg33)"
Local $sSubst = "${topro}\U${afterpro}\L${withoutpro}\E"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)