// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<topro>\([^)]*?\bpro +)(?<afterpro>.*?\))|(?<withoutpro>\(.*?\))").unwrap();
let string = "4377631753733131 (pro alber con tr33)
886uhghsdfdsfh (pro cios tui tr32)
rtyqrey 6y46457 6372576 (Flrt ghnap tsr)
537657QQRFytyvg (flipzz Reyhdf frfg33)
4377631753733131 (pro alber con tr33) (flipzz Reyhdf frfg33) (foo pro bar pro cios tui tr32)
I would like all words after \"pro\" to be capitalized. If \"pro\" is not present, all words in the brackets must be lowercase, for have :
4377631753733131 (pro Alber Con Tr33)
886uhghsdfdsfh (pro Cios Tui Tr32)
rtyqrey 6y46457 6372576 (flrt ghnap tsr)
537657QQRFytyvg (flipzz reyhdf frfg33)";
let substitution = "${topro}\\U${afterpro}\\L${withoutpro}\\E";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}