import re
regex = re.compile(r"(0[1-9]|1[012])\/([0][1-9]]|[12]\d|3[01])\/\d{2}\s[A-Z][a-z]{2}\s(\d|1[012])[ap]m")
test_str = ("he was out of city in period of 10/10/16 Sat 1am - 10/16/16 Sun 3am ₨350.00/hr - you have to remain onlines, which will enable you to meet him.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")