re = /(0[1-9]|1[012])\/([0][1-9]]|[12]\d|3[01])\/\d{2}\s[A-Z][a-z]{2}\s(\d|1[012])[ap]m/
str = 'he was out of city in period of 10/10/16 Sat 1am - 10/16/16 Sun 3am ₨350.00/hr - you have to remain onlines, which will enable you to meet him.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end