using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0[1-9]|1[012])\/([0][1-9]]|[12]\d|3[01])\/\d{2}";
string input = @"he was out of city in period of 10/10/16 Sat 1am - 10/16/16 Sun 3am ₨350.00/hr - you have to remain onlines, which will enable you to meet him.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}