const regex = /(0[1-9]|1[012])\/([0][1-9]]|[12]\d|3[01])\/\d{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[1-9]|1[012])\\\/([0][1-9]]|[12]\\d|3[01])\\\/\\d{2}', 'g')
const str = `he was out of city in period of 10/10/16 Sat 1am - 10/16/16 Sun 3am ₨350.00/hr - you have to remain onlines, which will enable you to meet him.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}