package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^"]*"$`)
var str = `Field1,Field2,Field3,Field4"
"Field1","Field2","Field3","Field4"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}