#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)['"]([ \w]+)?MATCH([ \w]+)?["']"
Local $sString = "I have a string like get(3,"No MATCH",obj). I want to check if the word MATCH is enclosed within quotes (either single quote or double quote). Here MATCH is enclosed within quotes, although not exactly as "MATCH", it is still a part of the text contained in quotes as "No MATCH"." & @CRLF & _
"I want to write a function which takes the word (MATCH) as argument and returns true if it is contained within quotes or false if not." & @CRLF & _
"Following are some other input strings which needs to be checked by this function:" & @CRLF & _
"* get(1101,"MATCH",obj) --> return true since MATCH is within quotes" & @CRLF & _
"* get(255,'NO MATCH',obj) --> return true since MATCH is a part of text contained within quotes" & @CRLF & _
"* get(1111,"" , MATCH) ---> return false since MATCH is not contained within quotes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")