package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)['"]([ \w]+)?MATCH([ \w]+)?["']`)
var str = `I have a string like get(3,"No MATCH",obj). I want to check if the word MATCH is enclosed within quotes (either single quote or double quote). Here MATCH is enclosed within quotes, although not exactly as "MATCH", it is still a part of the text contained in quotes as "No MATCH".
I want to write a function which takes the word (MATCH) as argument and returns true if it is contained within quotes or false if not.
Following are some other input strings which needs to be checked by this function:
* get(1101,"MATCH",obj) --> return true since MATCH is within quotes
* get(255,'NO MATCH',obj) --> return true since MATCH is a part of text contained within quotes
* get(1111,"" , MATCH) ---> return false since MATCH is not contained within quotes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}