using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!\.)[\w\-_+.]*[^.])(@\w+)(\.\w+(\.\w+)?[^.\W])$";
string input = @"lama.loca.loca123@inca.com
this+is+valid@email.com
pio_pio@factory.com
carnival666@hellmail.com
la-lalai@gmail.com
//INVALID EMAILS
//spaces at start
testmail@mail.com
//start with points
.testmail@mail.com
//finish with points
testmail@mail.com.
//spaces into the string
testm ail@mail.com
//Start/finish with any not number|letter char
testmail@mail.com.de
testmail@mail.de.org";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}